Lost photos from my obsy build thread

For reporting any problems or issues with the site.

Re: Lost photos from my obsy build thread

Postby Brutie » Fri May 06, 2016 7:32 pm

Hi Galileo et AL

No problem heheheh

I will setup a photo bucket shortly....been very busy on the obsy build this week and a few photos to be posted.

My paws are sore and cut though and back aches . Good progress though . Will post a full report on mybuild thread over the weekend.

Kind regards

Brutie

Hi, you are viewing as a guest, You can only see this first post in this topic. if you sign up you get access to other goodies you can't even see as a guest, including video tutorials on imaging and processing, scope modifications and even member discounts on gear!

So, give us a try, what have you got to lose! Oh, and if you stay, when you reach 50 posts you get access to MORE goodies! What are you waiting for!

User avatar
Brutie
Red Giant
 
Posts: 316
Joined: Fri Apr 05, 2013 3:07 am
Location: North Wales

Re: Lost photos from my obsy build thread

Postby Brutie » Mon May 23, 2016 7:07 pm

User avatar
Brutie
Red Giant
 
Posts: 316
Joined: Fri Apr 05, 2013 3:07 am
Location: North Wales

Re: Lost photos from my obsy build thread

Postby galileo » Mon May 23, 2016 7:33 pm

User avatar
galileo
Black Dwarf
 
Posts: 4617
Joined: Mon Jan 28, 2013 6:55 pm
Location: Chorlton cum Hardy Manchester

Re: Lost photos from my obsy build thread

Postby Brutie » Mon May 23, 2016 10:31 pm

User avatar
Brutie
Red Giant
 
Posts: 316
Joined: Fri Apr 05, 2013 3:07 am
Location: North Wales

Previous

Return to SITE ISSUES

Who is online

Users browsing this forum: No registered users and 2 guests